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Forms Designer Introduction
End users can easily be overwhelmed by their software. This is especially true if 
the screens contain numerous fields they do not use, field names that are not 
familiar to them, and the overall design is not efficient for their specific needs. 
You want the user’s environment to be simple, streamlined, and contain wording 
that is familiar to them. 
Everest currently allows users to make adjustments to their profile views, but not 
everyone feels comfortable or qualified to make these adjustments. In these 
situations, System Administrators can make customizations for the end users in 
advance that will be available to them when they log in to Everest. 
Profile customization is possible with the Everest Forms Designer utility. The 
System Administrator, or an advanced user with the appropriate Forms Designer 
security rights, can customize profile screens and even enhance security by 
limiting end user access in the profile. The Forms Designer moves customization 
control away from the end user to the System Administrator or another 
individual authorized to design forms.
The customized views that are created can then be assigned to specific users or 
groups of users. In this way, your existing and new end users can be set up 
quickly and easily. These customizations can give your end users a more 
favorable software experience and increase their productivity at the same time.

Features of Everest Forms Designer
The Everest Forms Designer enables the customization of the following screens:
• Customer Profile
• Vendor Profile
• Item Profile
• Sales Documents (Sales Opportunity/Sales Quote/Sales Order/Sales Invoice)
• Sales Return Documents (Credit Quote/Credit Order/Credit Memo)
• Purchase Documents (Purchase Quote/Purchase Order/Purchase Receipt/

Purchase Invoice)
• Purchase Return Documents (Debit Quote/Debit Order/Debit Memo)
• Document Aliases
• Custom Fields Profile (Ctrl + F from an available browser)
You can create different Custom Fields profiles for each browser type where it is 
available.  Customized Custom Field profiles are available for a variety of 
browsers including Sales Documents, Purchase Documents, Customer, Vendor, 
User, Item, and Serial Numbers. This allows you to view extended information 
from the Everest browsers. Customized Custom Fields profiles created through a 
sales document will display when accessed from all sales document browsers. 
Likewise, a customized Custom Fields profile designed for a purchase document 
displays when accessed from all purchase documents.
The Everest Forms Designer allows the authorized user to execute the following 
functions:
• Create Customized Profiles
• Assign Customized Profiles to Users
• Assign Customized Profiles to Groups
Everest Advanced Edition 3
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• Export a Form Version
• Import a Form Version
To ensure that you will retain your previously designed forms, you can export 
your customized form versions prior to an upgrade and then import them, if 
necessary, into your new version of Everest. You can also import customized 
form versions to update the existing form version.

Assumptions
• It is assumed that the user of the Forms Designer is either a System 

Administrator or a user designated to perform the Form Design function. The 
user of the Forms Designer does not have to be a programmer.

• End users will not normally be granted the ability to customize their profiles.
• It is assumed that the Everest Forms Designer is already operational on your 

system.

•  It is assumed that the user is already familiar with Everest Advanced Edition.

Document Structure
This user guide is organized into four chapters as shown in the following table: 

To activate the Forms Designer, see “The Forms Designer Utility” on 
page 105

Chapter 
Number

Chapter Name Description

1 Introduction Introduces you to Everest Forms 
Designer, identifies the audience 
and lists the document 
conventions.

2 Working with the Forms 
Designer

Explains the steps for creating 
customized profiles and when 
these profiles would be necessary. 

3 Working with the Forms 
Browser

Explains the steps for managing 
the created customized profiles 
including editing the profiles and 
assigning them to groups.

4 Forms Designer Security Describes the security, events, and 
licensing supporting the Forms 
Designer.
4 Everest Advanced Edition
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Forms Designer Introduction
Document Conventions
Following are the conventions used in this user guide to enable you to navigate 
easily through the information provided and help you accomplish your tasks 
quickly:
• Important information is mentioned using the “Note” symbol as seen below:

• A “Refer” symbol denotes references to other sections within the document or 
to other documents of the product documentation suite.

• Examples have been provided to illustrate the information presented. The 
example is mentioned using the symbol given below:

• Wherever there is a necessity to perform a sequence of tasks for a particular 
function, the “Steps” icon is used. This is indicated by the symbol given 
below:

• The keywords related to the software such as menu options, profile/dialog 
box names are highlighted in Boldface.

• Navigation between and through menu options is indicated by the symbol “> 
“.

You will see the icon on the left with the information appearing 
alongside.

You will see the icon on the left with the text for the cross-reference 
appearing alongside.

Example With this convention, you will see the icon on the left with the 
example appearing alongside.

You will see the icon on the left with the text appearing alongside 
indicating that the steps to carry out a task are listed.

Example To view the Forms browser, you must click File, Setup, and then 
Forms. This is explained in the document as follows:
From the main menu bar, select File > Setup > Forms.
Everest Advanced Edition 5
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Create Sample Customized Profiles
Create Custom Field Profile Forms for Extended Information Sample





Forms Designer Working with the Forms Designer
The Forms Designer
The Forms Designer allows the item, customer, vendor, and sales document 
profiles to be changed so that the look and feel of the profiles can be improved 
according to your business needs.

Access the Forms Designer
Only users with the proper security privilege and a valid license key can access 
the Forms Designer. On profiles that can be customized, a Design option displays 
on the Options menu. This option does not display on a profile that cannot be 
customized.

 Figure 2.1: Item Profile with Design Menu Option

• From the Options menu of a profile that can be customized, select Design.
• From the main menu bar, select File > Setup > Forms. Right click a profile 

template and select Design.
The Forms Designer displays the current form in Design view. Design view is 
indicated by “Design” next to the form title in the title bar. For example, when an 
Item profile is in design view, it is labeled Design-Item Profile.

To access the Forms Designer, do one of the following:
Everest Advanced Edition 9
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 Figure 2.2: Item Profile in Design View
When the Forms Designer opens, several dialog boxes open including the 
following:
• Field Chooser - Contains fields for the profile being designed
• Component Palette - Toolbox used to add windows controls 
• Object Inspector - Used to change object properties such as captions
The Standard or initial profile form loaded is called the Template. The version of 
the form that you are designing or editing is called the Target Form.

Field Chooser
The Field Chooser contains a tree view of all the fields available for the form. Use 
the Field Chooser to add tabs, groups, and controls to the target form. If you add 
an item that is grouped with other items, the additional items are added 
automatically. Each field can only be in one place on the target form. The Field 
10 Everest Advanced Edition
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Chooser dialog box is re-sizable and multiple items can be selected at the same 
time.

 Figure 2.3: The Field Chooser Dialog Box
The following field types are located in the Field Chooser dialog box:
• Missing Fields - The Fields that are missing from the target form are 

highlighted in the Field Chooser.
• Fields in Use - The fields used on the target form are not highlighted in the 

Field Chooser.
• Mandatory Fields - Mandatory fields are in bold. If a mandatory field is 

highlighted, it is a missing mandatory field that must be added to the target 
form.

Component Palette
The Component Palette displays window controls that can be added to the target 
form. If the controls are in the existing form, they are usually moved using the 
Field Chooser.

 Figure 2.4: The Component Palette Dialog Box
The following are examples of controls that can be added. These controls are not a 
part of the non-customized form:
• Picture Control - Adds a picture to the form
• Static Label Control - Adds static text to the form 

Example It adds additional text to a picture or adds help information to the 
screen.
Everest Advanced Edition 11
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• Group Box - Puts a box around items on the form
• Panel - Puts a raised area around items on the form

• Page Control - Adds a new tab to the form
Interactive controls, which capture and change data, cannot be added using the 
Component Palette. 

Object Inspector
The Object Inspector allows you to change certain properties of each control or 
object. When you click on an item in the target form, the properties of the control 
or object are displayed in the Object Inspector dialog box near the form. 
Mandatory fields are also highlighted in the Object Inspector.

 Figure 2.5: The Object Inspector Dialog Box
Here are some examples of properties that can be changed in the Object Inspector:
• Size
• Position
• Font
• Color
• Caption

Menu Options
In Design View, a Designer menu item is visible to use when customizing forms. 

To move groups of fields easily around a form, put the fields in a panel. A 
panel can also be placed in a group box.

To access the Menu Options, do the following:
12 Everest Advanced Edition
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Forms Designer Working with the Forms Designer
• From the profile (Design) menu, select Designer.

 Figure 2.6: Menu Options Available from Design View
Component Palette
This option opens the Component Palette dialog box. Use the Component Palette 
to add window controls to the target form.
Field Chooser
This option opens the Field Chooser dialog box. Use the Field Chooser to add 
fields to the target form.
Object Inspector
This option opens the Object Inspector dialog box. Use the Object Inspector to 
change the properties of controls and objects, such as caption name, position, font, 
color, and size.
Load
This time and effort saving feature allows you to choose a previously created 
version as the template for your target form. 
Save 
Use the Save option to save your current work to a new form. If the Standard 
Version of the form is edited and saved, it is saved as a different version. The 
Everest system checks the new form being saved for errors. A new form cannot be 
created until the errors are resolved.

 Figure 2.7: Save Form Dialog Box (Item Profile Example)
Everest Advanced Edition 13
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•  Form Name - Enter a unique name for your new form in this field.

 Figure 2.8: Save Form Dialog Box  (Customer Document Example)
• Document Alias - Specify the document alias that the new form will apply to.

Save As
Use the Save As option to give a version of the standard form a name or to save 
your current work as a previously saved version, replacing the earlier version.

 Figure 2.9: Save Form As Dialog Box (Item Profile Example)
•  Form Name - Enter a unique name for your new form in this field or enter the 

name of an existing form version to overwrite that version.

 Figure 2.10: Save Form As Dialog Box (Customer Document Example)
•  Document Alias - Specify the document alias that the new form will apply to.

Add Mandatory
This option adds all mandatory fields to a highlighted location on a target form, 
making it easier to create a form with all the mandatory fields on one tab.

“Sales and Purchase Document Form Version Assignments” on page 86

“Sales and Purchase Document Form Version Assignments” on page 86
14 Everest Advanced Edition
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Restore to Last Save
This option removes all edits completed before the last save. If you were creating 
a new version of a profile, the target form reverts to the form it was created from. 
Exit Design Mode
This function exits the Design view and returns you to the standard view. If 
changes were made to the current form, you will receive a dialog box concerning 
saving the changes.

Right Click Options
Right click on any object in the target form to display additional options. Standard 
windows options are available to undo, copy, cut, paste, and delete. The 
following standard windows options can be helpful when creating your new 
form design:
• Select the Alignment option to position an object horizontally and vertically 

on the target form.
• Select the Size option to change the size of the object on the target form. 
• Select the Tab Order option if you need to change the order of the tabs on the 

target form.

 Figure 2.11: Right Click Object Context Menu
Everest Advanced Edition 15
User Guide



Working with the Forms Designer Forms Designer
Create Customized Profiles
Create customized profiles for users when you want to simplify the user's view of 
the profile. The user's view can also be limited, when necessary, for security 
reasons.
It is important to keep in mind that you want to design the profile so it can be 
used efficiently. Field names can be renamed to names that the user is more 
familiar with. Fields can also be arranged to make it easier to key in the 
information. Profile menus and toolbars can also be customized.

Managing customized profiles including assigning profiles to users and groups 
will be discussed in the “Working with the Forms Browser” chapter.

In the section entitled “Create Sample Customized Profiles”, you can follow the 
steps to create sample customized profiles.

• From the Options menu of a profile that can be customized, select Design.
      Or
• From the main menu bar, select File > Setup > Forms.

Once you have designed a new profile, it is a good idea to test the profile 
after creating it to see if any adjustments need to be made before assigning 
the profile to users and groups. To test the profile, assign it to one user and 
have the user try it. Make any necessary adjustments and reassign the 
profile. When you are satisfied with the profile, assign it to additional users 
and groups.

“The Forms Browser” on page 79

“Create Sample Customized Profiles” on page 36

To create a customized profile using the standard profile template, do 
the following:
16 Everest Advanced Edition
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• Right click a standard profile template and select Design.
The Forms Designer is displayed with the target form in Design view. The Field 
Chooser, Component Palette, and Object Inspector are displayed near the target 
form. The target form displays the standard profile template.

 Figure 2.12: The Forms Designer

To create a profile from an existing customized profile instead of starting 
with the standard profile, do the following:

Skip this step if you want to start with the standard profile template.
Everest Advanced Edition 17
User Guide



Working with the Forms Designer Forms Designer
• From the Profile (Design) menu, select Designer > Load. The Load Form 
dialog box displays a list of versions of the profile that is being designed. 
Versions of other profiles do not appear here.

 Figure 2.13: The Load Form Dialog Box.
This saves you time by using a previously created version as a starting point for 
creating a new version.
• Browse to select the necessary form.
• Click OK to load it.
Design the target form by completing any combination of the following tasks, as 
necessary to complete your design.
Add Fields at the Cursor Position 

• Click on a field or item in the Field Chooser. You will see a Target icon 
underneath your cursor when your cursor is over a valid container for the 
drop.  If you do not see the Target icon, move your cursor until the Target 
icon is in view.

 Figure 2.14: Targeted Drop Cursor

To add fields at the cursor position on the target form using the Field 
Chooser, do the following:
18 Everest Advanced Edition
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• Click a location on the target form. The target icon is no longer underneath 
your cursor and the field or item is added to the target form.

 Figure 2.15: Field Added to the Target Form from the Field Chooser
• Press the Shift or Ctrl keys to select multiple items.
Add Fields to their Default Location

• Click on a field or item in the Field Chooser. You will see a Target icon 
underneath your cursor.

• Press and hold the Alt key. Now the Target icon changes to a Handbag icon.

 Figure 2.16: Handbag Drop Cursor
• Click a location on the target form. The handbag icon is no longer underneath 

your cursor and the field or item is added to the target form in the default 
position.  You must hold the Alt key when you click on the target for this 
feature to work properly.

You can cut and paste controls or objects to move them easily on the target form.  
The targeted drop cursor is not available with paste operations. Some controls or 
objects can also be copied but you will not be able to copy items that do not allow 
duplication. Right click any object to find these options.
Add Additional Controls

• Click on a control in the Component Palette.

To add fields to their default location on the target form, do the 
following:

To add additional controls using the Component Palette, do the 
following:
Everest Advanced Edition 19
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• Click a location on the target form. The control is added to the target form.

 Figure 2.17: The Component Palette - Text Control added to Target Form
Modify a Control or Object

• Click on a control or object to view its properties in the Object Inspector.

To change the properties of a control or object using the Object 
Inspector, do the following:
20 Everest Advanced Edition
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• Make the necessary changes in the Object Inspector.

 Figure 2.18: Editing the Text Control using the Object Inspector

 Figure 2.19: Changes Made in the Object Inspector are shown on the Target 
Form

Tab and Page Controls
In Design mode, you can highlight fields and controls and change their properties 
in the Object Inspector. Tab and Page “controls” can also be selected so that you 
can change their properties. A Tab Control is a control for an entire tab. A Page 
Control is a control for the entire page which includes all of the tabs. Both controls 

Certain controls change dynamically during runtime based on Everest 
functionality. In this situation, the control's other properties such as 
Position, Font, and Color can be changed but the text comes from Everest. 
For example, you cannot change a Sales Quote caption since the text comes 
from Everest.
Everest Advanced Edition 21
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are indicated by black dots. The Tab Control is used to add, rename, reorder, and 
delete tabs.

The following figure shows the Page Control selected. It is indicated by eight 
black dots surrounding the page including all of the tabs.

 Figure 2.20: Page Control
The next figure shows the Tab Control selected. It is indicated by eight black dots 
surrounding an individual tab page but it does not include the tab itself.
22 Everest Advanced Edition
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 Figure 2.21: Tab Control
It is important that you learn the difference between Tab Controls and Page 
Controls because if you use the Page Control instead of the Tab Control when 
working with tabs, you will not get the intended results.

Select the Page Control

• Click a field on a tab.
• Press the Esc key until the black dots are surrounding the page and just above 

the tabs. The Page Control is in focus and modifications can be made.
Select a Tab Control

• Click a field on the tab that you would like to modify.
• Press the Esc key until the black dots are surrounding only the tab page but 

not the tab itself. The Tab Control is in focus and modifications can be made.

Example If you want to select a tab to delete it, select the Tab Control for that 
tab. If you select the Page Control by mistake and press the Delete 
key, all of the tabs will be deleted.

To select the Page Control, do the following:

To select a Tab Control, do the following:
Everest Advanced Edition 23
User Guide



Working with the Forms Designer Forms Designer
Add a New Tab

• Select the Tab Control of a tab on the same level as the tab you are adding.
• Right click the Tab Control and select New Page.

 Figure 2.22: Tab Control with New Page Selected
• A new tab is added to your target form.

 Figure 2.23: New Tab Added to the Item Profile
Add a Dynamic Tab
Use the Field Chooser to add dynamic tabs to the target form. System dynamic 
tabs such as E-Commerce (Item profile), Multimedia, and Related Items are 

To add a new tab, do the following:
24 Everest Advanced Edition
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created in Everest at run time. While the content of these tabs cannot be designed, 
the tab properties can be changed.

• Click on a dynamic tab sheet in the Field Chooser. You will see a Target icon 
underneath your cursor when your cursor is over a valid container for the 
drop.  If you do not see the Target icon, move your cursor until the Target icon 
is in view.

 Figure 2.24: Targeted Drop Cursor
• Click a location on the target form. The target icon is no longer underneath 

your cursor and the Dynamic Tab is added to the target form.

 Figure 2.25: Dynamic Tab Added to the Target Form from the Field Chooser
You cannot edit objects contained within the tab control of a dynamic tab. You can 
only change the properties of the tab container (tab sheet).  For example, you can 
change the name of the dynamic tab and reorder a dynamic tab on the target 
form. If a dynamic tab is not mandatory, the tab can be deleted. You can add it 
again, if necessary.

To add a dynamic tab to the target form, do the following:

“Add the Tasks Tab to the Customer Profile” on page 35
Everest Advanced Edition 25
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Rename a Tab

• Select the Tab Control of the tab to be renamed.
• In the Object Inspector, in the Caption field, enter the new name for the tab. 

The tab is renamed to the new name entered.

 Figure 2.26: New Tab Renamed “Consumables”
Reorder Tabs

• Get the Tab Control in focus (select the Tab Control) for a tab you would like 
to reorder.

 Figure 2.27: “Consumables” Tab with PageIndex 9
• In the Object Inspector, in the PageIndex field, change the number of the tab to 

reflect its new position.
The PageIndex field indicates the order that the tabs are displayed to the user. 
They are numbered starting with zero (0, 1, 2, 3, 4, 5,...).

To change the name of a tab, do the following:

To reorder the tabs, do the following:

Example To move a tab with a page index of 9 to the left, change the page index 
for the tab in the Object Inspector to 8.
26 Everest Advanced Edition
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• Click the tab on the target form to change the tab position. The tab is moved to 
the new position.

 Figure 2.28: “Consumables” Tab Moved to the Left
Delete a Tab

• Get the tab control of the tab to be deleted in focus. (Select the tab control of 
the tab you would like to delete.)

• Press the Delete key. The tab is removed from the profile.

 Figure 2.29: “Consumables” Tab Deleted from the Profile
Change an Object’s Position

• Highlight one or more objects on the target form. (Press and hold the Shift key 
and click on the objects you want to select. Release the Shift key.)

To delete a tab, do the following:

To change an object's position, do the following:
Everest Advanced Edition 27
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• Right click the selected objects and select Alignment to change the objects’ 
horizontal and vertical position on the target form. The Alignment dialog box 
appears.

 Figure 2.30: The Alignment Dialog Box
• Click a horizontal alignment choice to select it.
• Click a vertical alignment choice to select it.
• Click OK after you have made your selections.
Change an Object’s Size

• Highlight one or more objects on the target form. (Press and hold the Shift key 
and click on the objects you want to select. Release the Shift key.)

• Right click the selected objects and select Size to change the objects’ height 
and width. The Size dialog box appears.

 Figure 2.31: The Size Dialog Box
• In the Width section, select the appropriate width option.
• If you selected Width, enter the width in the Width field.
• In the Height section, select the appropriate height option.
• If you selected Height, enter the height in the Height field.
• Click OK after you have made your selections.

To change an object's size, do the following:
28 Everest Advanced Edition
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Change the Tab Stop Order

• Right click any object and select Tab Order to change the order of the tab 
stops. The Tab Order dialog box appears.

 Figure 2.32: The Tab Order Dialog Box
• Use the Up and Down arrows to move the position of the tab stops.
• When you have arranged the tab stops in the appropriate order, click OK.

Make any Necessary Changes to the Menu and Toolbar

• Right click the Profile menu bar and select Customize. The Customize dialog 
box appears. Use the Toolbars tab to create new toolbars, rename, and delete 
them.

To change the order of the tab stops, do the following:

The Tab Order mentioned here is the tab stop order. This is the order that 
the fields come into focus when the end user presses the Tab key. This is 
different from the Order of the Tabs which is the order in which the tabs 
are displayed.

To make changes to the Menu and Toolbar, do the following:

Everest Advanced Edition User Guide > Volume I > Chapter 1 > Section - 
Add/Remove Toolbars
Everest Advanced Edition User Guide > Volume I > Chapter 1 > Section - 
Add/Remove Commands from a Toolbar
Everest Advanced Edition 29
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• On the Toolbars tab, click the New button. The Custom dialog box appears.

 Figure 2.33: Entering a New Toolbar Name Using the Customize Dialog Box
• Enter the new toolbar name and click OK.
• The Rename and Delete buttons are now activated for the new toolbar 

created.
• Click Close. The new toolbar is added to the profile.
• Right click the Profile menu bar and click Customize. The Customize dialog 

box appears.
• Click the Commands tab. 

 Figure 2.34: Customize Dialog Box Commands Tab
30 Everest Advanced Edition
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•  Highlight a Category and drag and drop Commands onto the new toolbar as 
necessary.

 Figure 2.35: A New Command Added to the New Profile Toolbar
Everest Advanced Edition 31
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• Click the Options tab. Select any additional menu or toolbar options.

 Figure 2.36: Customize Dialog Box Options tab

 Figure 2.37: Item Profile with Large Toolbar Icons
• Click Close.
Save
Once you have completed the necessary design changes to the target form, save it.

Click the Large Icons check box to increase the icon size on the toolbar 
making it easier for users to see them.
Everest Advanced Edition User Guide > Volume I > Chapter 1 > Section - 
Resize Icons

 To save the changes to a design, do the following:
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• From the Forms Designer menu, click Designer > Save. The newly created 
form is saved to the database.

 Figure 2.38: Form Version Example
• If the version has not been previously saved, the Save Form dialog box 

appears to allow you to enter a name for the newly created form.

 Figure 2.39: The Save Form Dialog Box
• In the Form Name field, enter a name for your form. The name must be 

unique for the versions of this profile.
If the standard version is edited and saved, the changes are saved as a new 
version. The standard version is then always available for use in its default form.
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• When finished, click OK. The system validates the form for errors and 
displays a message box alerting you to errors found.

 Figure 2.40: Errors on Save Message Box
• Correct any errors displayed and repeat the Save process. 

After you have corrected any errors and saved the newly designed form, the form 
is available to be assigned to users and groups. The new form does not become 
active until it is assigned.
Alternatively, you can select Save As when saving your newly created form. Use 
Save As if you want to give a version of the standard form a name or if you want 
to save your current work as a previously saved version, replacing the earlier 
version.
Save As

• From the Forms Designer menu, click Designer > Save As. The Save Form As 
dialog box displays the name of the form that was active when the Forms 
Designer was opened, the name of the last form loaded, or the name 
previously saved after the form was loaded.

 Figure 2.41: The Save Form As Dialog Box
• Enter a unique name for the form or select an existing form to replace it with 

your current work. 
• When finished, click OK. The system validates the form for errors and 

displays a message box alerting you to errors found. 
• Correct any errors displayed and repeat the Save As process.

You cannot save the new form until all errors are corrected. All 
mandatory fields must be visible, enabled, and contained in the new form.

To use Save As when saving your new form version, do the following:
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Reset Version

• Load the standard version of the form and save it as the version that needs to 
be reset.

Add the Tasks Tab to the Customer Profile
When designing a Customer profile form, you can add the customer Tasks tab to 
show related tasks, calls, and CRM Notes. It is not added to the target form by 
default.

• Click on the Tasks Tab Sheet (Tab Sheet -  Tasks) in the Field Chooser. You 
will see a Target icon underneath your cursor.

 Figure 2.42: Targeted Drop Cursor

To reset a version back to the standard version, do the following:

When the Forms Designer is enabled, the customizable forms do not allow 
menu and toolbar customization in normal mode.

To add the dynamic customer Tasks tab to the Customer profile, do the 
following:
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• Click a location on the target form. The target icon is no longer underneath 
your cursor and the dynamic customer Tasks tab is added to the target form.

 Figure 2.43: Tasks Tab Added to the Target Form from the Field Chooser
Because the customer Tasks tab is a system dynamic tab, you cannot change the 
tab contents using the Forms Designer. You are able to change the tab sheet 
properties, such as the name of the tab and its position on the target Customer 
profile form.

Create Sample Customized Profiles

To create a sample customized profile, you must be in Design view.

“Add a Dynamic Tab” on page 24

Example In the illustration that follows, you will create two sample customized 
profiles. The Everest software was purchased with the Forms 
Designer functionality and associated license key. You are logged in to 
the Everest system and your user account has permission to edit and 
assign custom forms.
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Open the Forms Designer

• Open the Items browser.
• Double-click an item to select it and open the Item profile.
• From the Options menu, select Design.
The Forms Designer appears with the target form in Design view. The word 
“Design” is located next to Item in the title bar. The Field Chooser, Component 
Palette, and Object Inspector are displayed near the target form. The target form 
displays the standard profile template.

 Figure 2.44: The Item Profile in Design View
You decide to close and reopen the Field Chooser, Object Inspector, and 
Component Palette.
Close and Reopen Dialog Boxes

• Click  in the upper right corner of the dialog boxes to close the Field 
Chooser dialog box, the Object Inspector, and the Component Palette. 

• Reopen the dialog boxes. From the Item profile, select Designer > Component 
Palette. The Component Palette is displayed.

• From the Item profile, select Designer > Object Inspector. The Object 
Inspector is displayed.

To open the Forms Designer from the Item profile, do the following:

To close and reopen the dialog boxes, do the following:
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• From the Item profile, select Designer > Field Chooser. The Field Chooser is 
displayed. 

You decide to create a customized field and make it required. Exit the Forms 
Designer to do this.
Exit the Forms Designer

From the Item profile, select Designer > Exit Design Mode. The screen refreshes 
to show the Item profile’s normal view.
Create a Mandatory Custom Field

• Click on the Custom Fields tab. 

• In the Characters tab, right click on the grid and select Properties. You will see 
the Custom Field Definition profile.

• Click the New icon.
• In the Field Name field, enter Perishable.
• The Field Type field should display “Characters”.

To exit the Forms Designer, do the following:

To create a custom field and make it mandatory, do the following:

Everest Advanced Edition User Guide > Volume I > Chapter 2 > Section - 
Create a Custom Field
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• Click in the box to select Mandatory.

 Figure 2.45: The Custom Field Definition Profile 
The Custom field can be made to display possible values, but for this example 
assume that the end user will type a value in the field. 
• Click Save to save the custom field.
Return to the Forms Designer to create a customized profile.
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Return to Design View

• From the Options menu, select Design. The Item profile is displayed in the 
Design mode.

 Figure 2.46: Item Profile in Design Mode
You decide to add your new custom field to a new tab in the Item profile.
Add New Custom Field to New Tab

• Click a field on the General tab.

To return to the Design view, do the following:

To create a new tab and add the new custom field to that tab, do the 
following:
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• Select the Tab Control of the General tab. (Press the Esc key until the black 
dots are surrounding only the tab page but not the tab itself.) The Tab Control 
is in focus and modifications can be made.

 Figure 2.47: Tab Control for General Tab

• Right click the Tab Control and select New Page. A new empty tab is added to 
the profile.

• In the Field Chooser, click the new Perishable field.

“Tab and Page Controls” on page 21
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• On the target form, click the new tab to add the Perishable field to it.

 Figure 2.48: Target Form Showing New Tab and Field
Change the label on the new tab to “Items”.
Change the Label

• On the target form, click on the new tab page. Notice that the properties of this 
object are displayed in the Object Inspector dialog box.

To change the label on the new tab, do the following:
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• In the Object Inspector dialog box - Caption field, type Items. The new tab is 
renamed to “Items”.

 Figure 2.49: New Tab Renamed to “Items”
You decide to remove the Perishable field from the “Items” tab, remove all tabs 
except the Items tab, and add all mandatory fields to the target form.
Remove a Field from a Tab

• Click on the new “Items” tab and delete the Perishable field. (Highlight the 
Perishable field and press the Delete key. Highlight the Perishable label and 
press the Delete key.) The Perishable field and label are removed from the 
tab.

Remove Tabs

• Get a tab to be deleted in focus. (Select the tab control of the tab to be deleted.)

• Press the Delete key. The tab is removed from the profile.

To remove the “Perishable” field from the “Items” tab, do the following: 

To remove all tabs except the “Items” tab, do the following:

“Tab and Page Controls” on page 21
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• Repeat the above steps to delete all of the remaining tabs except the “Items” 
tab.

 Figure 2.50: Item Profile Design Mode - All Tabs Removed except the Items 
Tab

Add all Mandatory Fields

• Click the new “Items” tab. (Select the Tab Control.)

To add all mandatory fields to the target form, do the following:
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• From the Designer menu, select Add Mandatory. All of the mandatory fields 
for the Item profile are added to the target form.

 Figure 2.51: Item Profile Design Mode - Add Mandatory Option

 Figure 2.52: Target Form Showing All Mandatory Fields on the Target Form

You must select an appropriate container, such as the Tab Control, before 
using the Add Mandatory menu option.
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Remove a Mandatory Field

• Select the mandatory Item Code field and label on the target form:
- Click the Item Code label.
- Press and hold the Shift key.
- Click the Item Code field.
- Release the Shift key.

 Figure 2.53: Target Form - Select Mandatory Field and Label
• Press the Delete key. The mandatory field and label are removed from the 

target form.

 Figure 2.54: Target Form - Mandatory Field Removed
Add a Field to a Group Box

• Click the Items tab.

• From the Component Palette, click the  Group Box icon, and click the 
target form to add it to the target form.

 Figure 2.55: Group Box
• Add a field from the Field Chooser into the Group Box on the target form.

To remove a mandatory field, do the following:

To add a field to a group box, do the following:
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• Select the Group Box to rename it. Change the name in the Caption field of the 
Object Inspector.

 Figure 2.56: A Field Added to the New Group Box
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Move Fields

• Highlight several fields together and drag them to the bottom of the target 
form.

 Figure 2.57: Target Form Showing Highlighted Fields

To move fields to a new location, do the following:
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 Figure 2.58: Target Form - Drag and Drop Fields

 Figure 2.59: Target Form Showing Fields Moved to the Bottom of the Target 
Form
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You are satisfied with your customization and decide to save the profile version.
Save

• From the Designer menu, select Save. A Warning dialog box is displayed 
since a mandatory field is missing.

 Figure 2.60: Warning Dialog Box
• Click OK to close the Warning dialog box and return to the Design View.
• In the Field Chooser, look for a mandatory field that is highlighted as missing.

 Figure 2.61: Field Chooser Showing a Mandatory Field that is Not on the Target 
Form

To save the new profile version (with a missing mandatory field), do the 
following:

In the Field Chooser, a mandatory field is in bold. A field is highlighted if it 
is missing from the target form.
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• In the Field Chooser, click the missing mandatory field. Click the new location 
on the target form. The missing mandatory field is now on the target form.

 Figure 2.62: Missing Mandatory Field Added to Target Form
• From the Designer menu, select Save. The Save Form dialog box is displayed.
• In the Form Name field, type Item Clerks.

 Figure 2.63: The Save Form Dialog Box (Item Clerks Entered)
• Click OK. The form is saved successfully.
• From the Designer menu, select Exit Design Mode to return to the normal 

mode. The system does not query for a save since no changes are made since 
the last save.

• Click Yes to exit the Forms Designer.
You decide to make a few changes to the newly created Item Clerks form to make 
another customized form.
Create Another Form Version

• To return to Design Mode, from the Options menu, select Design.
• From the Designer menu, select Load.

To create another customized form version from an existing form, do the 
following:
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• Click Yes to load another version of the form. The Load Form dialog box is 
displayed.

 Figure 2.64: The Load Form Dialog Box
• Select the Item Clerks form.
• Click OK. The previously saved version of the Item Clerks form is displayed.
• Make a few changes of your choice. Do not remove any mandatory fields for 

this exercise.
• From the Designer menu, select Save As. The Save Form As dialog box is 

displayed.
• In the Form Name field, type Items Clerks Trainees.

 Figure 2.65: The Save Form As Dialog Box (Items Clerks Trainees Entered in 
Form Name Field)

• Click OK to save your current changes.
• Exit design mode.
You decide to add the Notes tab to the form.
Add Tab

• From the Options menu, select Design. The Item profile is in Design Mode.
• From the Designer menu, select Load. 
• Click Yes to load another form version. The Load Form dialog box appears.
• Select the Item Clerks Trainees form.
• Click OK. The previously saved version of the Item Clerks Trainees form is 

displayed.

To add the Notes tab to the target form, do the following:
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• From the Field Chooser, click Tab Sheet - Notes and then click on the target 
profile. The Notes tab is added to the target form.

 Figure 2.66: Field Chooser - Tab Sheet - Notes Selected

 Figure 2.67: Notes Tab Added to Target Form
Make Additional Changes
Change item properties, add customizations, save the new form version, and 
return to normal view following the steps below.

To make additional changes, do the following:
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• Highlight the Item Code field and view the properties for the field in the 
Object Inspector. Notice that this is a mandatory field. The background 
changes color.

 Figure 2.68: The Item Code Field Properties in the Object Inspector.
• On the target form, select the Item Code label and field and drag them to the 

right.

 Figure 2.69: Target Form - Item Code Field Moved to the Right
You realize that you should not have moved the Item Code field and label.
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Undo Last Change

• Right click the target form and select Edit > Undo.

 Figure 2.70: Target Form - Edit Undo

 Figure 2.71: Target Form - Item Code Field in Original Position
Continue making changes to the target form.
• From the Component Palette, drag and drop one or more controls to the target 

form.
• Highlight any new control added and change the caption in the Object 

Inspector.

To undo the last change and move the Item Code field and label to their 
original position, do the following:

You cannot use the Undo function to undo a Delete.
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• Right click the Profile menu bar and select Customize to ensure that the 
menus and toolbars match. Use this feature to create and rename additional 
toolbars and menus, as needed.

 Figure 2.72: Example Profile - Item Clerks Trainees Form
• Save the Item Clerks Trainees form. The Item profile is returned to the Design 

View.
• Select Designer > Exit Design Mode to return to normal view.
Two new custom profiles are created and are ready for use.
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Create Custom Field Profile Forms for Extended Information 
Sample

Custom Fields profiles are accessible from various browsers including the sales 
documents browsers, such as the Sales Opportunity browser and the Sales Orders 
browser, and from the purchase document, Users, Customers, Vendors, Items, 
Tasks, and Serial Numbers browsers. You can access the Custom Fields profile 
from these browsers by entering Ctrl + F from within the browser.

Open the Custom Fields Profile

• Using the Sales Opportunity browser as an example, from the Sales 
Opportunity browser, select Options > Custom Fields or press Ctrl + F. The 
finished custom form will be accessible from all of the sales document 

The Custom Fields profile is also know as the Custom Fields dialog box.

Example PetProducts, Inc. is a pet food manufacturer and sells a variety of Pet 
Food and other products.  They have one marketing representative 
who researches and introduces new sales opportunities by visiting 
various wholesale dealers and distributors of pet food products.
The default Sales Opportunity profile in Everest displays much more 
information than they need to capture so they reorganized their Sales 
Opportunity profile using the Everest Forms Designer to show only 
Customer, Source, value, and pet food storage capabilities.  
They also need to capture the number of years that the dealerships 
have been in operation, and, in the case of distributors, the areas of 
operation. They wanted to access this information from the Sales 
Opportunity browser as extended information.
To do this, they customized the Custom Fields profile which is 
opened from the Sales Opportunity browser as well as the other sales 
document browsers.

To open the Custom Fields profile, do the following:
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browsers. You will see the Custom Fields profile that contains the custom 
fields applicable to the selected browser.

 Figure 2.73: Custom Fields Profile
Create Custom Fields

• Right click an existing custom field to be updated and select Properties. You 
will see the Custom Field Definition profile for the selected custom field. (If 
you do not have any default custom fields available, such as CUSTCHAR1, 

To create custom fields to use for extended information, do the 
following:
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from the Custom Field Definition profile, click the   New icon or press 
Ctrl + N to create a new custom field.)

 Figure 2.74: Custom Fields Profile - Select Properties
In the Field Name field, enter the name of the field as you want it to display in the 
Custom Fields profile.

 Figure 2.75: Areas of Operation Custom Field Example

Example Enter “Areas of Operation” to use for the distributors.
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•  The field type defaults to the field type of the custom field selected. (If you are 
creating a new custom field, select the Field Type from the drop down list.) 

 Figure 2.76: Years in Operation Custom Field Example

• Click   Save and Exit to save and exit the Custom Field Definition profile 
and return to the Custom Fields profile.

• Create additional custom fields as required. 
• Close and reopen the Custom Fields profile to view the newly created custom 

fields.
Open the Custom Fields Profile in Design Mode

In the Custom Fields profile, from the Options menu, select Design. The Everest 
Forms Designer appears with the target form in Design view. The Field Chooser, 

Example The “Areas of Operation” custom field has the Field Type 
“Characters” to be able to enter a value for the area. The “Years in 
Operation” custom field has the Field Type “Numerics” to be able to 
add a numeric value.

To open the Custom Fields profile in Design Mode, do the following:
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Component Palette, and Object Inspector are displayed near the target form. The 
target form displays the standard profile template.

 Figure 2.77: The Custom Fields Profile in Design Mode
• Rearrange the Custom Fields profile as needed for the extended information.

See the Create Customized Profiles and Create Sample Customized Profiles 
section for more detailed information on customizing the profile.

Example In the example that follows, a new "Opportunity" tab was added with 
sections for Wholesale Distributors and Wholesale Dealers. The 
custom field "Years in Operation" was added to the Wholesale Dealers 
section and the custom field "Areas of Operation" was added to the 
Wholesale Distributors section. Other tabs were removed.

“Create Customized Profiles” on page 16
“Create Sample Customized Profiles” on page 36
Everest Advanced Edition 61
User Guide



Working with the Forms Designer Forms Designer
Add a New Tab to the Custom Fields Profile

• Click inside the Characters tab. You should see eight black dots as shown 
below which indicate that the Tab Control is selected.

 Figure 2.78: Tab Showing Tab Control Selected

To add a new tab to the Custom Fields profile, do the following:
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• For our example, right click the Characters tab and select New Page to create a 
new tab.

 Figure 2.79: Select New Page to Create a New Tab
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 Figure 2.80: New Tab Created
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Delete a Tab in the Custom Fields Profile

• Click the Characters tab to select it. Notice that the page control is selected.

 Figure 2.81: Characters Tab with Page Control Select

To delete a tab in the Custom Fields profile, do the following:
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•  Click in the center of the Characters tab to select the Tab Control. Notice that 
this does not include the tab itself. We are going to delete a tab and do not 
want to delete the entire page.

 Figure 2.82: Characters Tab with Tab Control Selected.
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•  Press the Delete key to delete the tab.

 Figure 2.83: Characters Tab Deleted
Everest Advanced Edition 67
User Guide



Working with the Forms Designer Forms Designer
Delete the Remaining Tabs in the Custom Fields Profile

• Repeat the steps for the Delete a Tab in the Custom Fields Profile procedure 
for all of the other tabs except the new tab just created (TabSheet1).

 Figure 2.84: All Tabs except the New Tab Deleted

To delete the remaining tabs in the Custom Fields profile except the new 
tab just created, do the following:

You cannot delete tabs that contain mandatory fields.
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Rename a Tab in the Custom Fields Profile

• Click in the new tab and change the name in the Caption field of the Object 
Inspector on the left. In this example, the tab name is changed to 
“Opportunities”. 

 Figure 2.85: New Tab named “Opportunities”

To rename the new tab in the Custom Fields profile, do the following:
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Add Group Boxes in the Custom Fields Profile

• Click the Group Box icon and click the location on the tab where you want it to 
appear as shown below. In this example, we are adding two group boxes, one 
for Dealerships and one for Distributors.

 Figure 2.86: Group Boxes Added

To add group boxes in the Custom Fields profile, do the following:
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•  To rename a Group box, click a group box and change the caption name in the 
Object Inspector to the Left. In our example we will rename both group boxes.

 Figure 2.87: Rename Group Box (Dealerships)

 Figure 2.88: Rename Group Box (Distributors)
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Add Custom Fields to the Custom Fields Profile

• Click a custom field to the right and place your cursor over the area where you 
would like to place the custom field. You will see a target cursor.

 Figure 2.89: Target Form showing Target Cursor

To add your custom fields to the Custom fields profile, do the following:
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•  Click the target form in the Group Box to place the custom field on the form. 
Add the remaining fields.

 Figure 2.90: New Custom Field Added to the Target Form 
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 Figure 2.91: New Custom Field Profile Design

Save your New Custom Fields Profile Form 

• From the Designer menu, select Save and give your profile version a unique 
name. You may want to include the associate browser in the profile version 
name.

 Figure 2.92: Save Form

To save your new Custom Fields form, do the following:
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Test and Assign your New Custom Fields Profile Form to Users and 
Groups

• You must assign your profile version to a user or group for it to become active. 
See the Assign a Profile Version to a User or Group section for information 
on how to make the assignments.

•  To test the form, assign it to one user first to make sure that it is working 
correctly. Make any necessary adjustments. After you are comfortable with 
the form, you can assign it to other users. 

Once the profile is active, access the customized Custom Fields profile from 
the browser that you used to design it. For this example, it can be accessed 
from any sales document profile. You can create different Custom Fields 
profiles for each browser type where it is available.

To test and assign your new Custom Fields profile form, do the 
following:

“Assign a Profile Version to a User or Group” on page 82
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The Forms Browser
The Forms browser provides a central location to manage the customization of 
forms. Forms are created using the Forms Designer and managed using the 
Forms browser. The standard versions of each customizable profile are displayed 
in this list along with any form versions that were created using the Forms 
Designer. The Forms browser is only enabled for users with the appropriate 
security rights.

Access the Forms Browser

• From the main menu bar, select File > Setup > Forms. The Forms browser 
displays a list of all available forms.

 Figure 3.1: The Forms Browser
Form Class
This describes the class of the custom form version. (Example: Sales Quote, Sales 
Order, Sales Invoice, Credit Quote, Credit Order, and Credit Memo)
Form Name
This shows the name of the form versions available.
Document Class
This shows the name of the document class. (Example: Sales Documents and 
Purchase Documents)

“Access to Profile Version User/Group Assignment” on page 109

To access the Forms Browser, do the following:
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System 
The System form is the base form of all versions of each class and this cannot be 
edited or deleted. The edited system form versions can be saved in different name 
which enables the user to create the new form versions. 

Default
The Default form is the form version displayed when you access a profile or 
document absent any overriding form assignments.  In other words, the Default 
form is globally assigned to all users.  This global assignment is overridden by a 
group or user assignment. 

The form version a user sees when opening a profile is determined by the 
following Cascading Form assignments:
• User’s version assigned to you
• User group’s version assigned to your group 

• Default form assigned
• System form assigned

Type
This describes the type of the custom form versions (Example: Profile, Document 
etc.,) available in the Forms browser.

Forms Browser Options
Six options are available from the Forms browser:
• Design - Opens the selected profile in design mode
• Rename - Opens a dialog box for renaming the version
• Purge - Deletes the highlighted version or versions
• Assign Forms - Enables user and group assignment for the selected profile 

form
• Export Forms - Enables the user to export a customized form version to an 

external file

No form version can be set as a System form. The system form can be 
assigned to different users and groups and can be set as a Default form.   
The system form is set as the default form in the absence of a version being 
set as default.

Only one version can be the Default form for any form class. You can view 
the Default form for each form class in the Forms browser.  If no Default 
form is set, then the System form is set as the Default form.

If you are not assigned any form version and have multiple group 
assignments with different versions, then the system will choose the 
alphabetically first version.  

Authorized user with security rights can set a form version as a Default 
form. To set a form version as the Default form, right click on the form 
version and choose Set as default.
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• Import Forms - Enables the user to import customized form versions

 Figure 3.2: The Forms Browser with the Available Options Displayed

Design
This option enables you to quickly access a selected form in design mode to make 
any necessary changes.

Rename
Users with the appropriate security rights can rename a version of a form in the 
Forms Browser.

• Right click the version of a form to be renamed in the Forms browser and 
select Rename. The Rename Form dialog box is displayed.

 Figure 3.3: The Rename Form Dialog Box
• In the Form Name field, enter the new name for the form.

• When the standard versions of the profiles are the only versions 
available, the Rename, Purge, and Assign menu items are disabled.

• When a standard version is selected in the browser, Rename and Purge 
are disabled.

“The Forms Designer” on page 9

“Access to Customized Profiles from a Central Location” on page 110

To rename a version of a form, do the following:
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• Click OK to rename the form.

Purge
Only users with the appropriate security rights can purge or remove forms from 
the Forms browser.

• Highlight one or more rows containing form versions to be purged.
• Right click and select Purge. A confirmation dialog box displays a purge 

confirmation message.

 Figure 3.4: The Confirmation Dialog Box
• Click Yes to purge the selected forms.
Assign Forms
The Assign Forms option is used to assign form versions to users and groups.
Export Forms
Use the Export Forms option to export a customized form version to an external 
file.
Import Forms
Use the Import Forms option to import customized form versions that were 
created using Export Forms option from Everest database. 

Assign a Profile Version to a User or Group
Once a profile form version is saved, it can be assigned to a User or Group. When 
a user logs in, the profile assigned to the user is displayed. User assignments take 
precedence over group assignments. The standard version of each customizable 
profile is assigned to users and groups by default if no assignments are made.

The Rename option is always disabled for standard versions.

“Access to Customized Profiles from a Central Location” on page 110

The Purge option is always disabled for standard versions.

To purge one or more form versions, do the following:

Each user can only have one version of a profile active at one time.

Users with Forms Designer security rights should only be assigned to 
standard profiles so that all options are available to them.
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Assign a Profile Version from the Forms Browser
The Forms browser makes it easy to manage the customized profile forms that 
you create. Along with editing, renaming, and purging versions of profile forms 
that you create, assignments can be made and changed for users and groups from 
the Forms browser.

 Figure 3.5: The Forms Browser Assign Forms Option

Manage User Assignments

• Right-click the form version to be managed in the Forms browser.
• Select Assign Forms > Users to manage the form user assignments.
Manage Group Assignments

• Right-click the form version to be managed in the Forms browser.
• Select Assign Forms > Groups to manage the form group assignments.

Do not assign any forms other than the standard form to the user with the 
Forms Designer privilege. This ensures that all necessary design options are 
always available to that user.

To manage user assignments, do the following:

To manage group assignments, do the following:
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Assign Users to a Form Version
The Assign Forms dialog box for users displays the users that are assigned to the 
specific version of a form selected.

 Figure 3.6: The Assign Forms Dialog Box for Users

The Assign Forms dialog box for users (path: Forms Browser > Options > Assign 
Forms > Users) contains two sections: Assigned and UnAssigned.
Assigned Section
The Assigned section contains a list of the users assigned to the selected form.
UnAssigned Section
The UnAssigned section contains a list of users that can be assigned to the 
selected form.

• Move the user or users to be assigned from the UnAssigned section to the 
Assigned section using the arrow keys.

Do not assign any forms other than the standard form to the user with the 
Forms Designer privilege. This ensures that all necessary design options are 
always available to that user.

To grant users a version of a form, do the following:

Arrow Key Function

 Single Left Arrow
Moves a selected user to the section 
on the left

 Double Left Arrow
Moves all users to the section on the 
left
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• After the appropriate users have been assigned to the customized form 
versions, click Save.

Assign Groups to a Form Version
The Assign Forms dialog box for groups displays the groups that are assigned to 
the specific version of a form selected.

 Figure 3.7: The Assign Forms Dialog Box for Groups
The Assign Forms dialog box for groups (path: Forms Browser > Options > 
Assign Forms > Groups) contains two sections: Assigned and UnAssigned.     
Assigned Section
The Assigned section contains a list of the groups assigned to the selected form. 
UnAssigned Section
The UnAssigned section contains a list of groups that can be assigned to the 
selected form.

 Single Right Arrow
Moves a selected user to the section 
on the right

 Double Right Arrow
Moves all users to the section on the 
right

You can also double-click an item to move it from the UnAssigned section 
to the Assigned section and back without using the arrows.

 To grant groups a version of a form, do the following:

Arrow Key Function
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• Move the group or groups to be assigned from the UnAssigned section to the 
Assigned section using the arrow keys.

• After the appropriate groups have been assigned to the customized form 
versions, click Save.

Sales and Purchase Document Form Version Assignments
You can customize forms for the following Sales, Sales Return, Purchase, and 
Purchase Return documents (Customer and Vendor documents):
• Document Type - You can create customized forms for a particular document 

type (Sales Quote, Sales Order, Sales Invoice, Credit Quote, Credit Order, 
Credit Memo, Purchase Quote, Purchase Order, Purchase Receipt, Purchase 
Invoice, Debit Quote, Debit Order, or Debit Memo).

• Document Alias - You can assign custom forms for a specific document alias, 
such as a “Proposal” document alias for Sale Quote or a “Web Order” 
document alias for Sales Order.

You can create forms for the above sales and purchase document types, but you 
must assign your custom forms to users or groups of users before they can use 
them.
The following general rules apply to customized document form assignments:
• Customized document alias forms take precedence over customized 

document type forms assigned. For example, a “Web Order” custom 
document alias form assigned to a user has priority over any customized 
forms for the Sales Order document type.

• Custom forms assigned to a user (or group that the user belongs to) take 
precedence over custom forms set as a default. 

• If you do not assign customized forms to users and no customized form is set 
as a default, users will see the Everest forms included with the product out of 

Arrow Key Function

 Single Left Arrow
Moves a selected group to the section 
on the left

 Double Left Arrow
Moves all groups to the section on the 
left

 Single Right Arrow
Moves a selected group to the section 
on the right

 Double Right Arrow
Moves all groups to the section on the 
right

You can also double-click an item to move it from the UnAssigned section 
to the Assigned section and back without using the arrows.
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the box. These forms are known as System Forms and they cannot be assigned 
to users.

The following decision tree shows how the system determines the form to display 
for a user when the user opens a document alias.

 Figure 3.8: Decision Tree for Document Alias Form Display
When a user opens a document alias, if a customized document alias form is 
assigned to the user (or to a group that has the user as a member), the user sees 
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the customized document alias form. For example, the user sees a customized 
“proposal” document alias form.
If a customized document alias form is not directly assigned but there is a 
customized document alias form set as a default, the user sees the default custom 
document alias form. 
If there is no customized document alias form set as a default, the users sees the 
customized form for the specific document type assigned to the user (or to a 
group that has the user as a member).
If a customized form for the specific document type is not assigned but there is a 
customized form for the specific document type set as a default, the user sees the 
default custom form for the specific document type. For example, the user sees 
the customized sales quote form that is set as the default.
If there are no customized forms assigned or set as the default, the user sees the 
system form for the document type, such as the system sales quote form.

Example Susan is a member of the “Telephone Sales” group. The Telephone 
Sales group is assigned to the customized “Proposal” document alias 
form. A default customized sales quote (document type) form is set as 
the default. When Susan opens the “Proposal” document alias, she 
sees the customized “Proposal” document alias form and not the 
customized sales quote form since the customized document alias 
form takes precedence over the customized sales quote form.
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Managing Forms with the Forms Browser Illustrated

Assign a Form to Users from the Forms Browser

• From the main menu bar, select File > Setup > Forms. The Forms browser 
displays a list of all available forms.

• Right click the Item Clerks form (or another available form) and select Assign 
Forms > Users to manage the form user assignments.

• Highlight the user names to be assigned from the UnAssigned section and 

click the  button. The selected user names move to the Assigned section.

• Click Save to complete the assignment.
Delete a Form from the Forms Browser

• From the Forms browser, right-click the Item Clerk Trainees form (or another 
available form) and select Purge.

• Click Yes to purge the form. The Item Clerk Trainees form (or the selected 
form) is removed. 

Assign a Profile Version from the Users and Groups Browsers
When you are managing users and groups from the Users and Groups browsers, 
you can easily assign and change customized form versions for them.

Example This illustration is a continuation of “Create Sample Customized 
Profiles” in the previous chapter. If you do not have forms available to 
assign and delete, you can create the sample profile form versions in 
“Create Sample Customized Profiles” prior to following these steps.
Several days after you created profile form versions, you added all of 
the users to the system. You decide to assign forms to the end users. 
You no longer need your Item Clerk Trainee form and decide to purge 
it.

“Create Sample Customized Profiles” on page 36

To open the Forms Browser and assign a form to users from the Forms 
Browser, do the following:

To delete a form from the Forms Browser, do the following:

Do not assign any forms other than the standard form to the user with the 
Forms Designer privilege. This ensures that all necessary design options are 
always available to that user.
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Access the Assign Forms Dialog Box

• From the main menu bar, select File > Setup > Assign Forms > Users.

 Figure 3.9: Access the Assign Forms Dialog Box (Users Highlighted)

• From the main menu bar, select File > Setup > Assign Forms > Groups.

To access the Assign Forms dialog box for Users, do the following:

To access the Assign Forms dialog box for Groups, do the following: 
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Grant Users a Version of a Form

 Figure 3.10: Assign Forms Dialog Box from the Users Browser
The Assign Forms dialog box for users (path: File > Setup > Assign Forms > 
Users) contains three sections: Form Tree View, Assigned, and UnAssigned. 
Form
Displays the form version selected in the tree view below. This is a display only 
field.
Form Tree View Section
The Form tree view section contains a list of each customizable profile. Below 
those profiles in the tree view, are the customized versions of that profile that 
have been created in the Forms Designer.

Assigned Section
The Assigned section contains a list of the users assigned to the selected form.
UnAssigned Section
The UnAssigned section contains a list of users that can be assigned to the 
selected form.

• Highlight the customized form version in the Form tree view section.

The customized versions of the profile can have a different name than the 
name on the form header. The name on the form header can be customized 
using the Object Inspector in the Forms Designer.

To grant users a version of a form, do the following:
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• Move the user or users to be assigned from the UnAssigned section to the 
Assigned section using the arrow keys.

• After the appropriate users have been assigned to the customized form 
versions, click Save.

Grant Groups a Version of a Form

 Figure 3.11: Assign Forms Dialog Box from the Groups Browser
The Assign Forms dialog box for groups (path: File > Setup > Assign Forms > 
Groups) contains three sections: Form Tree View, Assigned, and UnAssigned.
Form
Displays the form version selected in the tree view below. This is a display only 
field.

Arrow Key Function

 Single Left Arrow
Moves a selected user to the section 
on the left

 Double Left Arrow
Moves all users to the section on the 
left

 Single Right Arrow
Moves a selected user to the section 
on the right

 Double Right Arrow
Moves all users to the section on the 
right

You can also double-click an item to move it from the UnAssigned section 
to the Assigned section and back without using the arrows.
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Form Tree View Section
The Form tree view section contains a list of each customizable profile. Below 
those profiles in the tree view, are the customized versions of that profile that 
have been created in the Forms Designer.
Assigned Section
The Assigned section contains a list of the groups assigned to the selected form.
UnAssigned Section
The UnAssigned section contains a list of groups that can be assigned to the 
selected form.

• Highlight the customized form version in the Form tree view section.
• Move the group or groups to be assigned from the UnAssigned section to the 

Assigned section using the arrow keys.

• After the appropriate groups have been assigned to the customized form 
versions, click Save.

Assign a Profile Version to a Specific User or Group
A profile version can be assigned to an individual user from the Users browser 
and the User profile. A profile version can also be assigned to a specific group 
from the Groups browser and the Group profile.

Access the Assign Forms Dialog Box from the Users Browser

• To access the Users browser, select File > Setup > Users > Users. The Users 
browser is displayed.

To grant groups a version of a form, do the following:

Arrow Key Function

 Single Left Arrow
Moves a selected group to the section 
on the left

 Double Left Arrow
Moves all groups to the section on the 
left

 Single Right Arrow
Moves a selected group to the section 
on the right

 Double Right Arrow
Moves all groups to the section on the 
right

You can also double-click an item to move it from the UnAssigned section 
to the Assigned section and back without using the arrows.

Do not assign any forms other than the standard form to the user with the 
Forms Designer privilege. This ensures that all necessary design options are 
always available to that user.

To access the Assign Forms dialog box for an individual user from the 
Users browser, do the following:
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• On the Users browser, highlight a user and select Options > Forms. 

 Figure 3.12: Users Browser with the Forms Option Selected
The Assign Forms dialog box for the selected user is displayed.

Access the Assign Forms Dialog Box from the User Profile

• To access the User profile, select File > Setup > Users > Users. The Users 
browser is displayed.

• Double-click to open a User profile. The selected User profile is displayed.
• From the User profile, select Options > Forms. 

 Figure 3.13: User Profile with the Forms Option Selected
The Assign Forms dialog box for the selected user is displayed.

To access the Assign Forms dialog box from the User profile, do the 
following:
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Access the Assign Forms Dialog Box from the Groups Browser

• To access the Groups browser, select File > Setup > Users > Groups. The 
Groups browser is displayed. 

• On the Groups browser, highlight a group and select Options > Forms.

 Figure 3.14: Groups Browser with the Forms Option Selected
The Assign Forms dialog box for the selected group is displayed.

Access the Assign Forms Dialog Box from the Group Profile

• To access the Group profile, select File > Setup > Users > Groups. The 
Groups browser is displayed.

• Double-click to open a Group profile. The selected Group profile is displayed. 
• From the Group profile, select Options > Forms.

 Figure 3.15: Group Profile with the Forms Option Selected
The Assign Forms dialog box for the selected group is displayed.

To access the Assign Forms dialog box from the Groups browser, do the 
following:

To access the Assign Forms dialog box from the Group profile, do the 
following:
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Individual User Assignment
The Assign Forms dialog box (path: User Browser or User Profile > Options > 
Forms) is used to view and assign forms for a selected user.

 Figure 3.16: Assign Forms Dialog box for a Selected User. 

The Assign Forms dialog box for a selected user shows all of the versions 
currently assigned to the user for each profile. The forms assigned could have 
come from a user, group, or default assignment. Users are assigned the standard 
profile by default. Only one version of any profile can be assigned to a user at any 
time.
User
The User field displays the selected user.
Form Class
The Form Class field contains a drop-down list that shows the available profiles.
Forms Assigned Section
The current form assigned to the user is displayed in the Forms Assigned section.
Forms UnAssigned Section
Available forms are displayed in the Forms UnAssigned section.

• From the Assign Forms dialog box for a selected user, select a profile from the 
Form Class drop-down list. The form assigned and the forms not assigned to 
that user are shown.

Do not assign any forms other than the standard form to the user with the 
Forms Designer privilege. This ensures that all necessary design options are 
always available to that user.

To view or edit a user assignment for a selected profile, do the following:
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• Change the form assignment as appropriate using the arrow buttons.

• Click Save to save your changes.

Specific Group Assignment
The Assign Forms dialog box (path: Group Browser or Group Profile > Options 
> Forms) is used to view and assign forms for a selected group.

 Figure 3.17: Assign Forms Dialog Box for a Selected Group. 
The Assign Forms dialog box for a selected group shows all of the versions 
currently assigned to the user for each profile. The forms assigned could have 
come from group or default assignment. Groups are assigned the standard profile 
by default. Only one version of any profile can be assigned to a group at any time. 
Group
The Group field displays the selected group.
Form Class
The Form Class field contains a drop-down list that shows the available profiles.

Arrow Key Function

 Single Left Arrow
Moves a selected form to the Forms 
Assigned section on the left and 
replaces it.

 Single Right Arrow
Moves the assigned form to the Forms 
UnAssigned section on the right. The 
Standard Form is automatically 
added to the Forms Assigned section.

You can also double-click an item to move it from the Forms UnAssigned 
section to the Forms Assigned section and back without using the arrows.
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Forms Assigned Section
The current form assigned to the group displays in the Forms Assigned section.
Forms UnAssigned Section
Available forms display in the Forms UnAssigned section.

• From the Assign Forms dialog box for a selected group, select a profile from 
the Form Class drop-down list. The form assigned and the forms not assigned 
to that user are shown.

• Change the form assignment as appropriate using the arrow buttons.

•  Click Save to save your changes.

Exporting a Form Version
Only users with the proper security privilege and a valid license key can access 
the Forms Designer and additional security rights are needed to view the Forms 
browser. 

Use the Export Forms option to export a customized form version to an external 
file. 

• From the Forms Browser, select the customized form versions to be exported.
• Select Options > Export Forms. You will see the Export Forms Dialog –Forms 

Browser dialog box.

To view or edit a group assignment for a selected profile, do the 
following:

Arrow Key Function

 Single Left Arrow
Moves a selected form to the Forms 
Assigned section on the left and 
replaces it.

 Single Right Arrow
Moves the assigned form to the Forms 
UnAssigned section on the right. The 
Standard Form is automatically 
added to the Forms Assigned section.

You can also double-click an item to move it from the Forms UnAssigned 
section to the Forms Assigned section and back without using the arrows.

“Assign Users to a Form Version” on page 84

To export customized form versions, do the following;

If there are no customized form versions in Forms Browser, the Export 
Forms option is disabled. 
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Export Forms Dialog Box
Use the Export Forms Dialog box to specify the export options such as File name, 
Location and Records to export.

 Figure 3.18: Export Forms Dialog Box
File Name
Specify the location and name of the output file in this field. Alternatively, you 

can click the Lookup  button, which displays the Save As dialog box.
Records to Export
Selected Records
Select this option to export only the custom form versions you selected in the 
browser.
You can select multiple forms by holding down the Shift or Ctrl key and clicking 
the required records.
Retrieved Records
Select this option to export all custom form versions in the browser. To retrieve 
more custom forms, click the Get button at the lower right corner of the browser. 
• Specify the export details and click Export button to export the custom form 

versions to the desired location.

Importing a Form Version
Use the Import Forms option to import customized form versions that were 
created using Export Forms option from Everest database. 

“Exporting a Form Version” on page 98

 You can use the imported custom form version to update the existing 
custom form version.

“Updating Existing Forms” on page  101

To import customized form versions, do the following;
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• From the Forms Browser, select Options > Import Forms. Click Import 
Forms. You will see the standard windows file Open dialog box.

• Specify the file name to be imported and click Open. You will see the Import 
Dialog – Forms Browser.

Import Dialog – Forms Browser
Use the Import Dialog-Forms browser to select and edit the custom form 
versions that you import. The Import Dialog-Forms Browser also provides the 
following functionality: 

- Lists the form versions being imported
- Highlights Name conflicts
- Enables version name editing
- Validates the imported form versions

 Figure 3.19: Import Forms Dialog Browser
You will see five columns in the Import Dialog – Forms Browser.
Check box 
The boxes are checked if the conditions are ok with the form versions being 
imported and the boxes are unchecked if there is name conflict in the form 
version.

Form Class
This describes the class of the imported custom form version. 

Checking the box on a row with a name conflict will cause the imported 
form version to overwrite the existing version with the same name.  This 
provides the ability to use the import to do updates. 
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Form name
This shows the name of the imported form version and you may edit the name in 
this column.
Type
This describes the type of the custom form version being imported.
Condition
This describes the status of the custom form versions being imported.  This 
column shows the following descriptions:

- OK - Displays for the Custom forms are OK to import.
- Existing Name - Displays if the name of the form being imported already 

exists.

If there is name conflict for the selected form version, you will see Existing Name 
in the condition column. To update an existing form version with an imported 
version of the same name, check the checkbox on the version row in the import 
browser.  Then, Click Import. You will see the confirmation screen. On the 
confirmation screen;
• Click Yes to update the existing form versions. If you selected multiple form 

versions for update, automatically moves to next selected form version and 
confirms one by one.

• Click No, if you do not want to update. The form version will not be imported.
• Click Yes to All to clear all of the form update warning messages.  All of the 

versions sharing a name with an existing form version will be updated.
• Click No to All to clear all of the form update warning messages.  The 

versions sharing a name with an existing version will not be imported.

Updating Existing Forms
The Everest import utility can be used to update existing form version definitions.  
Importing a form with the same name as the existing form will cause the existing 
form version to be overwritten with the imported version.  To do this, you must 
manually check the check box in the import forms browser on a row with a name 
conflict condition.  When you press the Import button, a warning message will 
appear for each form version that will overwrite an existing version.  You must 
say YES to update the form.  Alternatively, you may say YES TO ALL.

It is necessary to check the boxes for the selected form versions. Use left 
corner check box to check/uncheck all the form versions.

“Importing a Form Version” on page  99
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The Forms Designer Utility
The Forms Designer is a utility in Everest used to customize nine profile forms. 
These profile forms include the following:
• Customer Profile
• Vendor Profile
• Item Profile
• Sales Quote
• Sales Order
• Sales Invoice
• Credit Quote
• Credit Order
• Credit Memo
Because of the power of this customization tool, security features have been 
added to the Forms Designer to ensure that only authorized individuals can 
complete Forms Designer creation and management tasks. Profiles created should 
be consistent with the overall Everest implementation for a business and profiles 
assigned should be appropriate for the assigned users and groups.

Forms Designer events are logged in the Everest system. Each time a profile 
version is created, modified, removed or assigned, an entry is created in the log.
The Forms Designer is a licensed utility and requires a valid key to install. After 
installing the Forms Designer, all of the Forms Designer features, security, and 
events are activated and are ready for use.
Everest can be installed with or without the Forms Designer functionality. Either 
way, the Forms Designer feature will be visible from the Company Setup options 
(path: File > Setup > Company > Company Setup > Activation > Options). 

The Supervisor has global rights and can assign these rights to another user.

To activate the Forms Designer functionality with a valid license key, do 
the following:
Everest Advanced Edition 105
User Guide



Forms Designer Security Forms Designer
• From Company Setup profile, select the Activation tab > Options tab.

 Figure 4.1: Company Setup - Activation - Options Tab
• In the Activation Key field, enter your valid license key number.
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• Click Options > Save.

The following features are only visible and activated with a valid license key:

With proper activation, the user obtains access to all the Forms Designer features, 
security, and events.

Forms Designer Security Rights
In the Forms Designer utility, individual security rights are used to give 
authorized users the ability to create, rename, purge, import and export forms. 
Additional security rights are needed to view the Forms browser, assign forms to 
users, and assign forms to groups. These levels of security are necessary since the 
Forms Designer utility is a very powerful profile-customization tool and only 
qualified users should be able to customize profiles and assign them to other 
users.

Access to Forms Designer by Profile
Separate security rights are needed to create versions of each type of profile. For 
example, a user can be assigned rights to only create customized form versions for 
the Sales Quote, Sales Order, and the Sales Invoice. The user would then be 
restricted from creating customized form versions for the remaining customizable 
profiles.
Even though users have the Design item visible from the Options menu in their 
profiles, only users with the Design Form security right to the profile are able to 
open the Forms Designer for that profile. The user with security rights to a profile 

Everest Advanced Edition User Guide > Volume I > Chapter 2 > Section - 
The Company Setup Profile-Activation-Options.

Visible Features with License Key Path Activated
Design menu item on customizable 
profiles - Opens Forms Designer

Profile > Options > Design

Forms menu item from the main 
menu bar - Opens Forms Browser

Options > Setup > Forms

Assign Forms setup menu item - For 
assignments to Users and Groups

File > Setup > Assign Forms

Forms menu item from the User 
Browser and User Profile

User Browser > Options > Forms
User > Forms

Forms menu item from the Group 
Browser and Group Profile

Group Browser > Options > Forms
Group > Forms
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can also open the Forms Designer for that profile using the Forms browser. Users 
without the appropriate security rights receive a security message.
The profile security rights available and the paths that they activate are listed in 
the following table:

Security Right Path Activated
Item: Design Profile Form Item > Options > Design

Forms Browser > Design
Customer: Design Profile Form Customer > Options > Design

Forms Browser > Design
Vendor: Design Profile Form Vendor > Options > Design

Forms Browser > Design
Sales Document: Design Document 
Form

Sales Quote > Options > Design
Sales Order > Options > Design
Sales Invoice > Options > Design
Forms Browser > Design

Credit Document: Design Document 
Form

Credit Quote > Options > Design
Credit Order > Options > Design
Credit Memo > Options > Design
Forms Browser > Design
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Access to Profile Version User/Group Assignment
After users with the appropriate security rights create customized profiles and 
save them, they are known as profile versions. These profile versions must be 
assigned to users and groups before they become active. Additional security 
rights are needed to assign profile versions. The security right needed to assign 
profile versions to users is separate from the security right needed to assign 
profile versions to groups.

 Figure 4.2: Assign Forms Browser with User and Group Options
The users with the appropriate Assign Forms security rights can open the assign 
forms options as listed in the following table:

The distinction between these Assign Forms rights is important because the user 
with the Assign Forms right for Groups can quickly make global changes for 

Security Right Path Activated
User: Assign Forms File > Setup > Assign Forms > Users

User Browser > Options > Forms
User Profile > Options > Forms
Forms Browser > Options > Assign 
Forms > Users

Group: Assign Forms File > Setup > Assign Forms > Groups
Group Browser > Options > Forms
Group Profile > Options > Forms
Forms Browser > Options > Assign 
Forms > Groups
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groups of users. By separating these rights, the group assignment form rights can 
be restricted.

Access to Customized Profiles from a Central Location
The Forms browser is used to view and manage profile versions but not all users 
can open the Forms browser. The Forms browser can only be opened by a user 
with the View security right. This gives the user the ability to open and view the 
Forms browser only.

 Figure 4.3: Forms Browser Options
Additional rights are needed to create, assign, rename, purge, import and export 
profile versions. The Forms browser security rights are listed in the following 
table:

If users try to open the Forms browser without the associated security rights, the 
Forms browser will not open and they will receive a security message.

Security Right Path Activated
Form Browser: View File > Setup > Forms
Form: Rename Forms Browser > Options > Rename
Form: Purge Forms Browser > Options > Purge
Forms Browser: Export Forms Browser > Options > Export 

Forms
Forms Browser: Import Forms Browser > Options > Import 

Forms
Forms Browser: Set Default Form Forms Browser > Options > Set as 

Default
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Assign a Security Right to a User
Forms Designer security rights are added to users in the same way that other 
security rights are assigned in Everest.

• From the main menu bar, select File > Setup > Security Rights. The Security 
Rights browser is displayed.

• Verify that the Users tab is selected.

 Figure 4.4: Security Rights Browser - Users Tab
• In the Left Panel, locate and highlight the Forms Designer security right to be 

assigned.
• On the Users tab, in the Users Not Assigned section, highlight the user to be 

assigned the selected security right and click the   button to move the 
user's name to the Users Assigned section.

• Click Save to save your changes and assign the selected security right to that 
user.

To assign a Forms Designer security right to a user in Everest, do the 
following:

• You can also double-click an item to move it from the Users 
UnAssigned section to the Users Assigned section without using the 
arrows.

• Forms Designer security rights can similarly be assigned to groups of 
users using the Security Rights browser - Groups tab.

E

Everest Advanced Edition User Guide > Volume 1 > Chapter 1 > Section - 
Assigning Rights to Users
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Remove a Security Right from a User
Forms Designer security rights are removed from users in the same way that 
other security rights are removed in Everest.

• From the main menu bar, select File > Setup > Security Rights. The Security 
Rights browser is displayed.

• Verify that the Users tab is selected.
• In the Left Panel, locate and highlight the Forms Designer security right to be 

removed. 
• In the Users Assigned section, highlight the user to have the selected security 

right removed and click the   button to move the user's name to the 
Users Not Assigned section.

• Click Save to save your changes and remove the selected security right from 
that user.

Forms Designer Events
In order to ensure that the Forms Designer functionality is used properly, audit 
tracking is utilized to monitor activity. Management can then view the Forms 
Designer events in a log. Events are logged by the system when a profile version 
is created, modified, removed, or assigned. The following specific events are 
logged:
• A profile form is created
• A profile form is modified
• A profile form is deleted
• A user is assigned to a form
• A group is assigned to a form
For each event logged, the particular profile version of the form is also recorded. 

To remove an assigned Forms Designer security right from a user in 
Everest, do the following:

• You can also double-click an item to move it from the Users Assigned 
section to the Users UnAssigned section without using the arrows.

• Forms Designer security rights can similarly be removed from groups of 
users using the Security Rights browser - Groups tab
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